Roblox Core Outage
Resolved
Oct 22 at 11:27am EDT
All Roblox systems have been restored. https://status.roblox.com
Affected services
Updated
Oct 22 at 09:03am EDT
Some services seem to have been recovered. The Developer Forum is currently experiencing a prolonged outage. Stay posted https://status.roblox.com.
Affected services
Updated
Oct 21 at 09:56pm EDT
Services remain degraded with users reporting connection failures, data persistence failures, and social service failures.
Affected services
Created
Oct 21 at 04:00pm EDT
Roblox has been experiencing major system-wide failures. Stay updated with the situation on Roblox's official status page https://status.roblox.com.
Affected services